DGSI Slope Indicator
Home Products Downloads Support Contacts Projects News

DigiPro2 Software FAQ

Q: What is DigiPro2?

A: DigiPro2 is an inclinometer processing and graphing program. It replaces the original DigiPro and also DMM.


Question: Why did you replace the original DigiPro for Windows?

Answer: DigiPro and DMM were written in Microsoft VB6. Microsoft discontinued support for VB6 development tools some time ago, making bug fixes and further development nearly impossible. In addition, Microsoft warned that Windows 7 would not support for the VB6 runtime. In fact, there is some minimal VB6 runtime support in Win7, but it is certain that DigiPro and DMM will stop running in some future update of Windows.

For that reason, we developed DigiPro2 to replace both DMM and DigiPro. Development took over a year, but it is written in C# and is guaranteed to run on future updates of Windows. We encourage everyone to migrate to DigiPro2 sooner rather than later.

You can download a trial version of DigiPro2. It runs in advanced mode for 45 days, then it reverts to a basic version that you can continue to use.


Q: What happens to my inclinometer data when I switch to DigiPro2 ?

A: DigiPro2 can import surveys from DMM databases, so there is no loss of data when you switch. You can also import data from GTILT and other formats.


Q: How do I import my old DMM / DigiPro1 data?

A1: To convert a DMM database: Click File -> Convert DMM Database and choose your mdb file. DigiPro2 then creates a new .dpw database with the same name and same contents.

A2: To import DMM data into an existing .dpw database, click File -> Import -> DMM Data.


Q: Can DigiPro2 retrieve surveys from the DataMate?

A: Yes. DigiPro2 replaces DMM. You can find complete instructions on page 7 in the DigiPro2 manual. (O aqui para espaņol.)
Here is a summary of the steps:

  1. Connect DataMate to PC, switch on, and choose Comm.
  2. Start DigiPro2 and open a database (Open a dpw database, not an .mdb database).
  3. Click DataMate > Retrieve All or Retrieve New (same as DMM)

Q: DigiPro2 Basic and Advanced: What's the difference?

A: Please visit this page: Detailed Feature Comparison


Q: I've purchased DigiPro2 license keys. How do I receive them?

A: We send license keys by email. See "DigiPro2 License Keys" for complete information.


Q: I've been using the trial version of DigiPro2, but now I can't open reports. What's wrong?

A: The trial version runs in advanced mode for 45 days. After that, it reverts to "basic" mode unless you purchase a license key. The basic version still provides database management and simple plotting, but all advanced features, including reports, are disabled. Entering a license key restores the advanced features, including the ability to open reports.


Q: When I create a Profile Change plot DigiPro2 consistently plots graphs with one extra depth. Why is that? For example, when I survey an installation that has 23 depths, DigiPro always plots 24 depths.

A: Think of a measuring tape. The tape starts at zero. You don't record the zero, but it is the origin of your length measurements. Note that the plotted value for the extra depth is always zero. If your inclinometer installation is 12m deep, and you take readings at half-meter intervals, you will take 23 readings. Your bottom reading is taken at 11.5 meters, but the origin of that interval is at 12 meters. When DigiPro draws the plot, it establishes a zero at 12 meters.


Define ZonesQ: How do I set zones for the time plot?

A: Here are some instructions to get you started. A later version of the manual will document this fully.

  1. Identify the zones of interest using a change plot.
  2. Display the time plot.
  3. Right click on the plot and choose Define Zones.
  4. Enter top depth and bottom depth for as many zones as you need, then click OK.
  5. Next, right-click on the B-axis plot and choose Copy settings.
  6. Check Zones and then click OK.

Q: How can I use the settlement correction?

A: This is a two part process. The first part is entering settlement data for a particular inclinometer. The second part is applying settlement corrections to a particular inclinometer surveys.

Entering settlement data

1. Right click the Inclinometer. Select “Add Survey”. The survey dialog appears.

2. Set Survey Type to “Settlement”. Enter the initial settlement survey depths. Click “OK” to save the initial settlement survey (these are depths with units in meters or feet, as appropriate).

3. When you have new settlement data, repeat the steps above. You need a least two settlement surveys before you can apply a correction.

Applying a settlement correction

Now that you have settlement data in the system, DigiPro can make corrections.

1. Click on the Inclinometer Survey to be corrected. Click “Tools”, then “Apply Settlement Correction”. 

2. The Settlement correction dialog appears. By default, the earliest and latest settlement surveys will be selected as initial and current. Click OK. 

The change (settlement or heave) between the initial and current settlement surveys will be calculated and applied to the selected Inclinometer Survey. The original survey will be left unchanged, and a new corrected Inclinometer survey will be created with the same date but with minutes and seconds set to 59:59.


Q: How can I enter a borehole log?

A: Here are some instructions to get you started. A later version of the manual will document this fully.

  1. Select an inclinometer.
  2. Click Edit > Add/Edit Boring Log. A dialog appears.
  3. Right-click in the gray box to add a zone.
  4. Enter legend, top depth, and bottom depth in the text area below.
  5. Choose texture and color, then click X to close and choose save.
  6. Generate a plot.

Q: How can I export data to Atlas?

A: DigiPro can exported plotted data to Atlas.

  1. Create a plot in DigiPro2. Make any corrections needed. Decide
  2. Open Plot Options in the settings panel.
  3. Double click "Use Elevations" to make it "True". This works even if no elevations are entered.
  4. Click Export and choose a path and filename. Set file type to " Atlas files (.dat)."
  5. Set the upload program (such as FTP Scheduler) to upload the file.
  6. Enter the inclinometer as a "sensor" in Atlas with A and B channels. Use the data file names in step 4.
  7. Create a vertical profile plot in Atlas. You must make one plot for the A and one plot for the B. You can display the two plots side by side by creating a "side by side" plot.

Q: I imported my mdb database, but my templates aren't available. How can I retrieve them?

A: Templates were stored in a special "templates.mdb" file in the DigiPro\system folder and were not part of the normal inclinometer database file.

  1. Copy the file “c:\program files\digipro\system\templates.mdb” to your document directory.
  2. Open DigiPro2 and use the DMM database import function to import the template.mdb file.

Q: Can you help me communicate with the DataMate?

A: Please take a look at this page: DataMate Communications FAQ.

 

 

 

DGSI Information